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Copyright
The documentation and the software included with this product are copyrighted 2018
by Advantech Co., Ltd. All rights are reserved. Advantech Co., Ltd. reserves the right
to make improvements in the products described in this manual at any time without
notice. No part of this manual may be reproduced, copied, translated or transmitted
in any form or by any means without the prior written permission of Advantech Co.,
Ltd. Information provided in this manual is intended to be accurate and reliable.
However, Advantech Co., Ltd. assumes no responsibility for its use, nor for any
infringements of the rights of third parties, which may result from its use.
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Product Warranty (5 years)
Advantech warrants to you, the original purchaser, that each of its products will be
free from defects in materials and workmanship for five years from the date of
purchase. 
This warranty does not apply to any products which have been repaired or altered by
persons other than repair personnel authorized by Advantech, or which have been
subject to misuse, abuse, accident or improper installation. Advantech assumes no
liability under the terms of this warranty as a consequence of such events.
Because of Advantech’s high quality-control standards and rigorous testing, most of
our customers never need to use our repair service. If an Advantech product is
defective, it will be repaired or replaced at no charge during the warranty period. For
out of-warranty repairs, you will be billed according to the cost of replacement
materials, service time and freight. Please consult your dealer for more details.
If you think you have a defective product, follow these steps:
1. Collect all the information about the problem encountered. (For example, CPU 

speed, Advantech products used, other hardware and software used, etc.) Note 
anything abnormal and list any on screen messages you get when the problem 
occurs.

2. Call your dealer and describe the problem. Please have your manual, product, 
and any helpful information readily available.

3. If your product is diagnosed as defective, obtain an RMA (return merchandise 
authorization) number from your dealer. This allows us to process your return 
more quickly.

4. Carefully pack the defective product, a fully-completed Repair and Replacement 
Order Card and a photocopy proof of purchase date (such as your sales receipt) 
in a shippable container. A product returned without proof of the purchase date 
is not eligible for warranty service.

5. Write the RMA number visibly on the outside of the package and ship it prepaid 
to your dealer.

Printed in Taiwan Edition 1
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 Declaration of Conformity
CE

This product has passed the CE test for environmental specifications. Test conditions
for passing included the equipment being operated within an industrial enclosure. In
order to protect the product from being damaged by ESD (Electrostatic Discharge)
and EMI leakage, we strongly recommend the use of CE-compliant industrial
enclosure products.

FCC Class A

Note: This equipment has been tested and found to comply with the limits for a Class
A digital device, pursuant to part 15 of the FCC Rules. These limits are designed to
provide reasonable protection against harmful interference when the equipment is
operated in a commercial environment. This equipment generates, uses, and can
radiate radio frequency energy and, if not installed and used in accordance with the
instruction manual, may cause harmful interference to radio communications.
Operation of this equipment in a residential area is likely to cause harmful
interference in which case the user will be required to correct the interference at his
own expense.

Technical Support and Assistance
1. Visit the Advantech web site at www.advantech.com/support where you can find 

the latest information about the product.
2. Contact your distributor, sales representative, or Advantech's customer service 

center for technical support if you need additional assistance. Please have the 
following information ready before you call:
– Product name and serial number
– Description of your peripheral attachments
– Description of your software (operating system, version, application software, 

etc.)
– A complete description of the problem
– The exact wording of any error messages
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Warnings, Cautions and Notes

Document Feedback
To assist us in making improvements to this manual, we would welcome comments
and constructive criticism. Please send all such - in writing to:
support@advantech.com

Packing List
Before setting up the system, check that the items listed below are included and in
good condition. If any item does not accord with the table, please contact your dealer
immediately.
 1 x Serial Device Server
 1 x DIN-Rail Mounting Bracket and Screws

Warning! Warnings indicate conditions, which if not observed, can cause personal 
injury!

Caution! Cautions are included to help you avoid damaging hardware or losing 
data. e.g.
There is a danger of a new battery exploding if it is incorrectly installed. 
Do not attempt to recharge, force open, or heat the battery. Replace the 
battery only with the same or equivalent type recommended by the man-
ufacturer. Discard used batteries according to the manufacturer's 
instructions.

Note! Notes provide optional additional information.



v EKI-1511 Series User Manual

 Safety Instructions
 Read these safety instructions carefully.
 Keep this User Manual for later reference.
 Disconnect this equipment from any DC outlet before cleaning. Use a damp 

cloth. Do not use liquid or spray detergents for cleaning.
 For plug-in equipment, the power outlet socket must be located near the equip-

ment and must be easily accessible.
 Keep this equipment away from humidity.
 Put this equipment on a reliable surface during installation. Dropping it or letting 

it fall may cause damage.
 The openings on the enclosure are for air convection. Protect the equipment 

from overheating. DO NOT COVER THE OPENINGS.
 Make sure the voltage of the power source is correct before connecting the 

equipment to the power outlet.
 Position the power cord so that people cannot step on it. Do not place anything 

over the power cord.
 All cautions and warnings on the equipment should be noted.
 If the equipment is not used for a long time, disconnect it from the power source 

to avoid damage by transient over voltage.
 Never pour any liquid into an opening. This may cause fire or electrical shock.
 Never open the equipment. For safety reasons, the equipment should be 

opened only by qualified service personnel.
 If one of the following situations arises, get the equipment checked by service 

personnel:
– The power cord or plug is damaged.
– Liquid has penetrated into the equipment.
– The equipment has been exposed to moisture.
– The equipment does not work well, or you cannot get it to work according to 

the user's manual.
– The equipment has been dropped and damaged.
– The equipment has obvious signs of breakage.

 DO NOT LEAVE THIS EQUIPMENT IN AN ENVIRONMENT WHERE THE 
STORAGE TEMPERATURE MAY GO -40°C (-40°F) ~ 85°C (185°F). THIS 
COULD DAMAGE THE EQUIPMENT. THE EQUIPMENT SHOULD BE IN A 
CONTROLLED ENVIRONMENT.

 The sound pressure level at the operator's position according to IEC 704-1:1982 
is no more than 70 dB (A).
DISCLAIMER: This set of instructions is given according to IEC 704-1.
Advantech disclaims all responsibility for the accuracy of any statements
contained herein.
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Safety Precaution - Static Electricity
Static electricity can cause bodily harm or damage electronic devices. To avoid
damage, keep static-sensitive devices in the static-protective packaging until the
installation period. The following guidelines are also recommended:
 Wear a grounded wrist or ankle strap and use gloves to prevent direct contact to 

the device before servicing the device. Avoid nylon gloves or work clothes, 
which tend to build up a charge.

 Always disconnect the power from the device before servicing it.
 Before plugging a cable into any port, discharge the voltage stored on the cable 

by touching the electrical contacts to the ground surface.
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 1.1 Overview
The EKI-1511 series focus on the entry level device server market, providing an
economic solution that is designed to connect RS-232 or RS-422/485 serial devices
such as PLC, meters, sensors, and barcode readers to an IP-based Ethernet LAN.
This allows nearly any device with a serial port to connect and share an Ethernet
network, while also providing various operations such as COM port redirection
(Virtual COMport), TCP server, TCP client, and UDP mode. With COM port
redirection mode, standard serial operation calls are transparently redirected to the
servers, guaranteeing compatibility with legacy serial devices and enabling
backward-compatibility with existing software. With TCP server, TCP client, and UDP
modes, the EKI-1511 series ensure compatibility in network software using a
standard network API. Serial devices can communicate with other devices via 
peer-to-peer, thus eliminating the need for an intermediate host PC and software
programming.

1.2 Device Features
 1 x 10/100 Mbps Ethernet port
 Provides COM port redirection (Virtual COM), TCP, and UDP operation modes
 Baud rate supports up to 230.4 kbps
 Maximum of five hosts can access one serial port
 Maximum of 16 hosts accessed in TCP client mode
 Built-in 8-kV ESD protection for all serial signals
 Provides multiple configuration configuration methods including Windows utility, 

Telnet console, and web browser. Supports 32/64-bit Windows 2000/XP/Vista/7/
8/8.1/10, Windows Server 2003/2008/2012, and Linux

 "I" models support a wide operating temperature
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 2.1 Specifications

Specifications Description
Interface I/O Port EKI-1511L: 1 x RJ45 + 1 x RS-232

EKI-1511IL: 1 x RJ45 + 1 x RS-232
EKI-1511X: 1 x RJ45 + 1 x RS-422/485

Power Connector Terminal block
Physical Enclosure Metal with solid mounting hardware

Installation DIN-rail and Wall mount
Dimensions 
(W x H x D)

46 x 85.1 x 21.2 mm (1.81" x 3.35” x 0.83”)

LED Display System LED Power, Status
Port LED Status/LAN: Speed, Link/Active

Serial: Tx, Rx
Environment Operating 

Temperature
-10°C ~ 60°C (14°F ~ 140°F)
I models: -40 ~ 75 °C (-40 ~ 167 °F)

Storage 
Temperature

-40°C ~ 85°C (-40°F ~ 185°F)

Ambient Relative 
Humidity

10 ~ 95% RH

Ethernet 
Communications

Compatibility IEEE 802.3, IEEE 802.3u
Speed 10/100 Mbps
Port Connector 1 x 8-pin RJ45
Protection Built-in 2.25 k VDC magnetic isolation

Serial 
Communications

Port Type L: RS-232; X: RS-422/485
Port Connector 1 x DB9 male
Data Bits 5, 6, 7, 8
Stop Bits 1, 1.5, 2
Parity None, Odd, Even, Space, Mark
Flow Control XON/XOFF, RTS/CTS
Baud Rate 300 bps ~ 230.4 kbps
Serial Signals RS-232: TxD, RxD, CTS, RTS, GND

RS-422: TxD+, TxD-, RxD+, RxD-, GND
RS-485 2-wire: Data+, Data-, GND
RS-485 4-wire: TxD+, TxD-, RxD+, RxD- GND

Protection Built-in 8 KV ESD for all signals
Power Power 

Consumption
1W

Power Input 9 ~ 36VDC

Software Driver Support 32-bit/64-bit Windows 2000/XP/Vista/7/8/8.1/10, 
Windows Server 2003/2008/2012, and Linux

Utility Advantech EKI Device Configuration Utility
Operation Modes  COM port redirection mode (Virtual COM)

 TCP/UDP server (polling) mode
 TCP/UDP client (event handling) mode
 Pair connection (peer to peer) mode

Configuration Windows utility, Telnet Console, Web Browser
Management SNMP MIB-II
Protocols ICMP, IP, TCP, UDP, BOOTP, DHCP, Auto IP, SNMP, 

HTTP, DNS, SMTP, ARP, NTP
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Regulatory 
Approvals

EMC CE, FCC Part 15 Subpart B (Class A)

Specifications Description
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 2.2 Hardware
2.2.1 Front View

Figure 2.1 Front View

No. Item Description

1. Terminal block Connect cabling for power wiring

2. Serial port DB9 pin-out, supports L: RS-232, X: RS-422/485

3. System LED panel See “LED Indicators” on page 9 for further details.

4. Ground terminal Screw terminal used to ground chassis

Status
RX
TX Default

LNK /
ACT

ON:100M
OFF:10M 9-36 VDC

EK
I-1

51
1

4

1

3

2
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2.2.2 Rear View

Figure 2.2 Rear View

2.2.3 Top View

Figure 2.3 Top View

No. Item Description

1. M2 screw holes Screw holes (2) used in the installation of a DIN mounting 
bracket or wall mounting

1

No. Item Description

1. ETH port RJ45 ports x 1

2. Terminal block Connect cabling for power wiring

1
2
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 2.2.4 Bottom View

Figure 2.4 Bottom View

Left View

Figure 2.5 Left View

No. Item Description

1. Serial port DB9 pin-out, supports L: RS-232, X: RS-422/485

2. Reset button  Reset to factory default, press and hold until status 
indicator blinks

 System reboot, press and hold for 2 seconds
3. System LED panel See “LED Indicators” on page 9 for further details

No. Item Description

1. Ground terminal Screw terminal used to ground chassis

2. M2 screw holes Screw holes (4) for DIN brackets or wall mounting

13

2

2

1
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2.2.5 LED Indicators

Figure 2.6 System LED Panel

2.2.6 Dimensions

Figure 2.7 Dimensions

No. LED Name LED Color Status Description

1. Status/Power Blue, blinking On Heartbeat (1 time/sec.)
Off Off System is not working

2. Rx (Serial) Amber On Data being received
Off No data being received

3. Tx (Serial) Green On Data being transmitted
Off No data being transmitted

Status
RX
TX Default

1
2
3
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 2.3 Connecting Hardware
2.3.1 DIN Rail Mounting

The DIN rail mount option is the quickest installation option. Additionally, it optimizes
the use of rail space.
The metal DIN rail kit is secured to the rear of the switch. The device can be mounted
onto a standard 35 mm (1.37”) x 7.5 mm (0.3”) height DIN rail. The devices can be
mounted vertically or horizontally. Refer to the following guidelines for further infor-
mation.

2.3.1.1 Installing the DIN-Rail Mounting Kit
1. Align the provided DIN bracket with the device. The bracket can be installed on 

the left or rear side of the device to accommodate various environments. For 
this demonstration, the bracket is depicted on the rear of the device. 

2. Insert the provided screws and tighten them to secure the bracket to the device.

Figure 2.8 Installing the DIN Bracket
3. Position the rear panel of the switch directly in front of the DIN rail, making sure 

that the top of the DIN rail clip hooks over the top of the DIN rail, as shown in the 
following illustration.

Make sure the DIN rail is inserted behind the spring mechanism.

Note! A corrosion-free mounting rail is advisable.
When installing, make sure to allow for enough space to properly install 
the cabling.

Warning! Do not install the DIN rail under or in front of the spring mechanism on 
the DIN rail clip to prevent damage to the DIN rail clip or the DIN rail.

DIN rail clip

DIN rail clip 
release tab
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4. Once the DIN rail is seated correctly in the DIN rail clip, press the front of the 
switch to rotate the switch down and into the release tab on the DIN rail clip. 
If seated correctly, the bottom of the DIN rail should be fully inserted in the
release tab.

Figure 2.9 Installing the DIN-Rail Mounting Kit
See the following figure for an illustration of a completed DIN installation proce-
dure.

Figure 2.10 Correctly Installed DIN Rail Kit
5. Grasp the bottom of the switch and slightly rotate it upwards. If there is 

resistance, the switch is correctly installed. Otherwise, re-attempt the installation 
process from the beginning.

DIN rail clip

DIN rail

DIN rail clip 
release tab
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 2.3.1.2 Removing the DIN-Rail Mounting Kit
1. Ensure that power is removed from the switch, and disconnect all cables and 

connectors from the front panel of the switch.
2. Push down on the top of the DIN rail clip release tab with your finger. As the clip 

releases, lift the bottom of the switch, as shown in the following illustration.
\

Figure 2.11 Removing the DIN-Rail
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2.3.2 Wall-Mounting
The wall mounting option provides better shock and vibration resistance than the DIN
rail vertical mount.

Before the device can be mounted on a wall, you will need to remove the DIN rail
plate.
1. Align the wall mounting plate with the rear side of the device. The screw holes 

on the device and the mounting plates must be aligned, see the following figure.
2. Secure the wall mount plates with the provided screws, see the following figure.

Figure 2.12 Installing Wall Mount Plates
Once the wall mounting plates are secure on the device, you will need to attach
the wall screws (x 2).

3. Locate the installation site and place the mount plate against the wall, making 
sure it is the final installation location.

4. Use the plates as a guide to mark the locations of the screw holes.
5. Drill two holes over the marked locations on the wall, keeping in mind that the 

holes must accommodate the width of the wall sinks in addition to the screws.
6. Insert the wall sinks into the walls.

Note! When installing, make sure to allow for enough space to properly install 
the cabling.
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7. Insert the screws into the wall sinks. Leave a 2 mm gap between the wall and 
the screw head to allow for wall mount plate insertion.

Figure 2.13 Securing Wall Mounting Screws

8. Align the wall mount plate over the screws on the wall.
9. Install the wall mount plate on the screws and slide in the direction to lock it over 

the keyhole, see the following figure.

Figure 2.14 Wall Mount Installation
10. Once the device is installed on the wall, tighten the screws to secure the device.

2.3.3 Power Adapter Connection
Three types of power adapters are provided to accommodate power requirements.
The adapter types are as follows: 

Note!  Make sure the screws dimensions are suitable for use with the wall 
mounting plate.

 Do not completely tighten the screws into the wall. A final 
adjustment may be needed before fully securing the wall mounting 
plates on the wall.

8.0 mm

4.0 mm

2.0 mm

1

1 2



EKI-1511 Series User Manual 15

 OPT1-PSU12V05-US Power Adapter 12v 0.5A US
 OPT1-PSU12V05-EU Power Adapter 12v 0.5A Europe
 OPT1-PSU12V05-UK Power Adapter 12v 0.5A UK
The following figure depicts a typical power adapter. The figure also describes the
labels for the electrodes. 

Figure 2.15 Power Adapter Electrode Label Indication

2.3.4 Serial Connection
EKI-1511 Series provides a single DB9 (male) connector. RS-232 pin assignments
are illustrated as follows:

Figure 2.16 DB9 Pin Assignment

EKI-1511X Series provides a single RS-422/485 connector. The RS-422/485 pin
assignments are illustrated as follows:

Figure 2.17 RS-422/485 Pin Assignment

Positive(+) electrode, 
indicated by a white line

Negative(-) electrode, 
indicated without a white 
line

Pin 1 2 3 4 5 6 7 8 9
RS-232 - RX TX - GND - RTS CTS -

Pin 1 2 3 4 5 6 7 8 9
RS-422 (RS-
485-4W)

TX- TX+ GND RX+ RX-

RS-485 DATA- DATA+ GND

1
96
5

1
96
5
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2.3.5 Power Connection

2.3.5.1 Overview

1. Insert the power wire from DC power supply into the power contacts of the 
terminal lock connector on the EKI device.

2. Tighten the terminal screws to prevent the DC wires coming loose.
3. Switch on the DC power supply.
If the EKI-1511 Series is working properly, the blue power LED will light up, indicating
that the EKI-1511 Series is receiving power.
The EKI-1511 Series supports dual 9 to 36 VDC power inputs and power-fail relay out-
put.

Figure 2.18 Power Wiring for EKI-1511 Series

Warning! Power down and disconnect the power cord before servicing or wiring 
the serial device server.

Caution! Do not disconnect modules or cabling unless the power is first switched 
off.
The device only supports the voltage outlined in the type plate. Do not 
use any other power components except those specifically designated 
for the serial device server.

Caution! Disconnect the power cord before installation or cable wiring.

9-36 VDC
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3Utility Configuration



18 EKI-1511 Series User Manual

 3.1 Installing the Configuration Utility

1. Insert the Advantech EKI Device Configuration Utility CD-ROM into the CD-
ROM drive (whereas E:\ is the drive name of your CD-ROM) on the host PC.

2. Use Windows explorer or the Windows Run command to execute the setup 
program.

3. If there is an existing COM port mapping utility on the host PC, remove it at this 
time. A system reboot may be necessary before continuing the installation.

4. Once the InstallShield Wizard screen displays, click Next to proceed with the 
installation.

Figure 3.1 InstallShield Wizard 1 of 4

Note! Microsoft.NET Framework version 2.0 or greater is required for this 
application.
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5. The Software License Agreement displays, press I Agree to continue or Cancel 
to stop the installation.

Figure 3.2 InstallShield Wizard 2 of 4
The InstallShield continues and a status screen displays. The default installation
path is C:\Program Files\EKI Device Configuration Utility.

Figure 3.3 InstallShield Wizard 3 of 4
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6. Once the installation of the package is finished a Configuration Utility Setup 
screen displays. Click Finish to conclude the process and exit the InstallShield 
Wizard.

Figure 3.4 InstallShield Wizard 4 of 4
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3.2 Starting the Configuration Utility
Advantech EKI-1511 Series device servers provide an easy-to-use utility to configure
your serial device server through an Ethernet connection. For secure administration,
it can also restrict the access rights for configuration to only one host PC. With this
secure function enabled, other PCs will not have permission for configuration. After
the installation program on the Advantech IEDG Series Driver Utility CD-ROM is
finished, the serial device servers are ready for use and configuration.
Advantech Serial Device Server Configuration Utility is an excellent device server
management tool. You can connect and configure the local and remote Advantech
serial device servers easily. The utility provides access to the following functions:
 Configure the network settings (you can set the IP address, Gateway address, 

and Subnet mask)
 View and set the serial port parameters (configure operating mode, baud rate, 

serial port settings and operating mode settings)
 Perform diagnostic tests (virtual COM port testing, port status list)
 Perform administrative functions (export and import the serial device server set-

ting, manage access IP, a descriptive name, upgrade firmware)
You can open the Configuration Utility from the Windows Start Menu by clicking Start
> All Programs > EKI Device Configuration Utility > EKI Device Configuration
Utility. The Configuration Utility displays as shown in the following figure.

Figure 3.5 Configuration Utility Overview

No Item Description
1 Menu Bar Displays File, View, Management, Tools and Help.
2 Quick Tool Bar Useful management functions shortcuts.
3 Serial Device Server 

List Area
Available devices are listed in this area. Devices and COM ports 
can be organized or grouped in this area. 

4 Information Panel Click on the devices or move cursor to the devices, the related 
information is shown in this area.

5 Status Bar Displays the current time.
6 Configuration Area Click on the item on the Device Server List Area, the configura-

tion page displays. 

5

4

3

2

6

1
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 3.3 Discovering Your Device Server
3.3.1 Auto Searching

Advantech Serial Device Server Configuration Utility will automatically search all the
EKI-1511 Series device servers on the network and show them on the Serial Device
Server List Area of the utility. The utility provides an auto-search function to show
your device (s) by simply executing the configuration utility program from the Start
Menu.
From here all device on the same network domain will be searched and displayed on
Device Server List Area. You can click on the device name to show the features of
the specific device. 
Click on the “+” before the model name, and the utility will expand the tree structure
to show the individual device name. Click on the “-” before the model name, and the
utility will collapse the tree structure.

Figure 3.6 Open View of Serial Device Configuration Utility

Select the device in this sub-tree. The first tab on the Configuration Area shows the
summary of “Basic Information” included device type, version, and name, “Ethernet

Note! When you run the configuration utility for the first time, the default device 
name is obtained from the serial device’s MAC identification number. 
The name can be altered through the configuration utility.
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Information”, and “Serial Port Information”. The serial port information frame displays
the operation mode, status and connected host IP.

Figure 3.7 Selecting a Group
Click on the “+” before the device name, and the utility will expand the interfaces on
this device server.

Figure 3.8 Selecting a Device
Click on each item to enter the configuration page to change the setting. The
configuration will be introduced on following sections.

Figure 3.9 Viewing Basic Settings
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 3.3.2 Network Settings
Prior to setting up the server’s IP address determine the IP address mode.
There are four mode types available:
 Static IP: mode to assign a specific assigned address
 DHCP / AutoIP: mode to automatically assign IP addresses through a DHCP 

server
 BOOTP / AutoIP: mode to automatically assign an IP address through the con-

figuration server
 DHCP/BOOTP/AutoIP: mode to automatically assign an IP address using a 

Bootstrap Protocol or DHCP server.
The server is set with the following default IP configuration:
 10.0.0.1 (Eth1)
The EKI-1511 Series includes a software utility option, which you can install on your
system, for configuration through computer-based software. The EKI-1511 Series
also includes a web interface option for configuration through a standard web
browser.

Figure 3.10 Utility Overview
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You can choose from four possible IP Configuration modes --- Static, DHCP, BOOTP,
and DHCP/BOOTP.

Figure 3.11 Network Settings Overview

Item Description
Static IP Static IPUser defined IP address, Subnet Mask, and Default Gateway.
DHCP + Auto-IP DHCP Server assigned IP address, Subnet Mask, Default Gateway, 

and DNS.
BOOTP + Auto-IP BOOTP Server assigned IP address.
DHCP + BOOTP + 
Auto-IP

DHCP Server assigned IP address, Subnet Mask, Default Gateway, 
and DNS, or BOOTP Server assigned IP address. (If the DHCP 
Server does not respond)

DNS Setting In order to use DNS feature, you need to set the IP address of the 
DNS server to be able to access the host with the domain name. The 
EKI-1511 Series device server provides Primary DNS Server and 
Secondary DNS Server configuration items to set the IP address of 
the DNS server. Secondary DNS Server is included for use when Pri-
mary DNS server is unavailable.

DHCP Advanced 
Setting

When you enabling DHCP protocol to get IP address, it will be waited 
DHCP server to give IP within DHCP time out. The default value is 30 
seconds.

Note! When you have finished the configuration of these settings for each cat-
egory, please press the “Apply” button in order to make these settings 
effective on the Serial Device Server.
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 3.4 Administrator Settings
3.4.1 Locate the Serial Device Server

When several serial device servers are connected to the network, identification of a
specific serial device is possible through the Locate function.
To locate the serial device server:
1. From the device list frame, locate the desired device and right-click on it to dis-

play the settings menu.
2. Select Locate from the menu.

Figure 3.12 Locate the Serial Device Server
The unit’s Status LED lights solid blue until you click Stop Locate.
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3.4.2 Securing the Serial Device Server

3.4.2.1 Lock the Serial Device Server
The configuration utility provides the “Lock Device” function to make it more secure.
To lock the serial device server:
1. Right-click a desired device to display the settings menu.
2. Select Lock Device.

Figure 3.13 Lock the Serial Device Server
3. Enter a password. Retype the password entry to confirm the profile password.

Figure 3.14 Enter a Password
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4. Right-click a desired device to display the settings menu. Select Reset Device 
to restart the serial device server and store your setting password into the 
memory.

Figure 3.15 Reset Device

3.4.2.2 Unlock the Serial Device Server
To unlock the serial device server:
1. Right-click a desired device to display the settings menu.
2. Select Unlock Device.
3. Enter the password as entered in the Lock Device procedure.

Figure 3.16 Unlock the Serial Device Server
If you forgot the password, you must restore the setting of the serial device server to
the factory defaults, which will be introduced in the next section.
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3.4.3 Restore to Factory Default Settings
The configuration utility provides the function to restore the serial device server to
factory default settings. 

Figure 3.17 Restore to Factory Default Settings
The confirm message will display after clicking Restore to Factory Default
Settings. If you really want to restore the serial device sever to factory default
settings, please click Yes button to continue.
Power off the serial device server within ten seconds. After reconnecting the power,
all settings will be reset to the factory default. If the power supply remains connected
for more than ten seconds, the serial device server will not be changed.
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 3.4.4 Resetting the Device
The Reset Device is available to allow you to reset the serial device server. The
function disconnects both the ethernet and serial connections.
The function also allows the serial device server to save new configuration settings to
flash memory. Once a new setting is changed, you can use the Save function to
accept the changes. You will need to reset the device to save the settings to flash
memory.
To reset the device:
1. Right-click a desired device to display the settings menu.
2. Select Reset Device.

Figure 3.18 Reset Device
The device resets. Once the process is complete, the serial device server displays
under the Serial Device Server listing once again.
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3.4.5 Add to Favorite
The Add to Favorite function allows to easily map available devices to Favorite’s. By
bookmarking specific devices, you can create quickly accessible shortcuts for
existing critical devices from the vast pool of locally or remotely networked EKI-1511
Series devices.

Figure 3.19 Add to Favorite

3.4.6 Auto Mapping
See “Auto Mapping” on page 42 for further details.

3.4.7 Manual Mapping
See “Manual Mapping” on page 44 for further details.
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 3.4.8 Update Firmware
Advantech continually upgrades its firmware to keep up with the ever-expanding
world of computing. You can use the update firmware function in the utility to carry
out the upgrade procedure. Please access Advantech’s website: http://
www.advantech.com to download the latest version of the firmware. Before updating
the firmware, make sure that your host’s Network domain is as same as the serial
device server or the host can establish the TCP connection to the serial device
server.
To update firmware:
1. Right-click a desired device to display the settings menu.
2. Select Update Firmware.

Figure 3.20 Update Firmware
3. Select the firmware file you want to update.
Wait for a few seconds for the firmware to finish updating. After the update has
completed, click on the OK button. The serial device server will restart automatically.

Note! Be sure that the host PC Ethernet network domain is as same as the 
EKI-1511 Series serial device server or the host PC can establish the 
TCP connection with the serial device server while doing the updating 
firmware process.
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 4.1 Overview
The EKI-1511 Series is designed to network-enable any RS-232/422/485 serial
device, an provides industry-grade hardware and easy-to-use software to make
connecting serial devices to an Ethernet network a surprisingly simple process.
These units immediately upgrade your existing serial devices for integration into the
Internet world. The EKI-1511 Series features many powerful functions, such as high
speed data transfer, access-control, auto-detection of all EKI-1511 Series products,
and more.
After the simple installation steps to attach your network and serial device to the
appropriate connectors on the serial device servers and driver installation, you will be
able to communicate with the serial devices via its own application software and wit
the EKI-1511 Series device server. COM port redirector, USDG TCP server mode,
TCP client mode, UDP server mode, UDP client mode, RFC2217 mode are all
different methods of making a serial connection across using one or more serial
device servers.

4.2 COM Port Redirector (Virtual COM Port)
Advantech EKI Device Configuration Utility is a serial COM port redirector that
creates virtual COM ports and provides access to serial device connected to
Advantech serial device server. You can configure the serial device server and
enable the Virtual COM port using one integrated utility. Advantech EKI Device
Configuration Utility allows you to configure Microsoft applications to communicate
with network enabled serial device servers as easily as if they were physically
installed in or directly connected on the PC. 
The Advantech redirector can create up to 255 virtual COM ports. Application to the
host can open a virtual COM port to access the serial device servers at the same
time. The redirector will handle each active virtual COM port as a separate TCP
connection to Advantech serial device servers.

Figure 4.1 Virtual COM Mode
The EKI-1511 Series provides Multi-access function through an Ethernet connection
path, allowing a maximum of five connections to open one serial port simultaneously.
In this mode all connections must use the same serial setting. If one serial setting
within this configuration is configured differently, the data communication will not
function correctly.

SCADASCADASSSSCCCAAADDAAAAASSCCAADDAAASSSSSCCCAAADDAAASSSCCAADDASCADA
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EKI 1511
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Figure 4.2 Configuring Virtual COM Mode
The Host Idle Timeout setting monitors the connection between the host and the
device. If the Host Idle Timeout setting time is reached, the device server will release
the resources allocated to the port mapping. This prevents a stalled host from
affecting the connective device.
The Multi-access function has two modes. One is Normal mode and the other is
Round-Robin mode.

4.2.1 Normal mode
By disabling the Response Timeout parameter, the EKI-1511 Series will operate in
normal mode. When multiple hosts simultaneously open the serial port, only the first
connected host obtain management control, the remaining connections only have
data communication function. Each serial port supports up to five simultaneous
connections, so multiple hosts can transmit/receive data to/from the same serial port
simultaneously. Every host can transmit data to the same serial port, and the EKI-
1511 Series will also transmit data to every hosts. When the multiple hosts transmit
data to the same serial port at the same time, the received data from Ethernet and
the outputs of serial port are mixed. When the EKI-1511 Series receives data from
serial port, the data will also be transmitted to the connected hosts simultaneously.

4.2.2 Round-Robin mode
By enabling the Response Timeout parameter, the EKI-1511 Series Series operates
in “Round-Robin mode”. Each serial port supports up to five simultaneous
connections allowing hosts to simultaneously transmit/receive data to/from the same
serial port. Every host can simultaneously transmit data to the same serial port, EKI-
1511 Series processes the data in the order arrived. The EKI-1511 Series processes
the first host’s request and replies. The serial device server determines the end of the
serial acknowledgment through a response timeout. When EKI-1511 Series serial
device server does not receive a response from the serial port after a response
timeout query, the device replies with an acknowledgment and then processes the
next host request. With an increased number of hosts, response time may be lengthy,
increasing the period of the Response Timeout. 
Frame Break is an important parameter for Round Robin mode. The parameter is a
smart method of reducing ineffective waiting periods and streamlining the
transmission process. 
If the Frame Break function is disabled, EKI-1511 Series devices will wait for a
“Response Timeout” period, whether or not the device has transmitted data. During
this period, the host commands are queued and processed in the order received. 
If Frame Break is enabled, the serial port idle is longer than the Frame Break period.
The EKI-1511 Series assumes the communication is completed and continues with
the next query. This is an efficient way to reduce waiting time and improve
performance.
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 4.3 USDG Data Mode
The EKI-1511 Series can function as either a Data TCP server or a Data TCP client.
Both operations support TCP and UDP protocol. The EKI-1511 Series allows you to
treat your serial devices as if they were networking devices. You can issue
commands or transmit data from serial devices, connected to a EKI-1511 Series
device, to any devices that are connected to the Internet.

4.3.1 USDG TCP Client Mode
In TCP Client mode, the TCP connection is established from the EKI-1511 Series
device server. This operation mode supports a maximum of 16 simultaneous
connections for each serial port on EKI-1511 Series to one host or several hosts. You
can configure the IP address and TCP port number of the network hosts connected
to the EKI-1511 Series device server using the Advantech Serial Device Server
Configuration Utility. After configuring the devices, when the EKI-1511 Series device
server receives the data from the serial port, and the device server connects to the
hosts which are configured.

Figure 4.3 USDG TCP Client Mode
In USDG Data TCP Client mode, you may need to enable the peer numbers you
would like to receive. You can set a maximum sixteen network devices to which you
may connect. You need to fill out the IP Address and Port (including local port and
peer port) of each network device to which you want to connect. 
In the Peer for Receiving Data menu, entering “0” as the value for the Local Port will
assign a random TCP Port for an EKI-1511 Series device.

Figure 4.4 Peers for Receiving Data
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4.3.2 USDG Data TCP Server mode
In TCP server mode, the TCP connection is initiated from the host to the EKI-1511
Series device server. This operation mode supports a maximum of five simultaneous
connections for each serial port on an EKI-1511 Series device server from a single or
multiple hosts. However a multi-host connection simultaneously transmits the data
from a single serial port.

Figure 4.5 USDG TCP Server Mode

Figure 4.6 USDG Data Mode

4.3.3 USDG UDP Server/Client mode
The USDG UDP mode is primarily used for the broadcasting of messages over a
network. In UDP server mode, data is transmitted from the Host connected to the
EKI-1511 Series USDG UDP Port (Default Port 5300). In the default UDP client
mode,   EKI-1511 Series device servers simultaneously transmits UDP messages to
a maximum of 16 peers.
USDG Data mode supports Data Idle Timeout, Data Listen Port, and Command
Listen Port parameters.

4.3.3.1 Data Idle Timeout
The default is 60 seconds. If you want to keep connection continually, you can
disable the Data Idle Timeout. Data idle Time is the time period for which the device
waits for data. If the EKI-1511 Series does not receive data during established idle
time, the EKI-1511 Series will disconnect temporarily. When the data comes in, it will
reconnect automatically. Users do not need to reconnect.

IP 192.168.1.1

Ethernet
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2/485
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IP 192.168.1.24

Ethernet

IP 192.168.1.1
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 4.3.3.2 Data Listen Port
The TCP/UDP port number represents the source port number, and the number is
used to identify the channel for remote initiating connections. The port range is 1024-
65533. If an unknown caller wants to connect to the system and request services,
they must define the TCP/UDP port to carry a long-term conversation. 
Each node on a TCP/IP network has an IP address, and each IP address can allow
connection on one or more TCP port. The well-known TCP ports are those that have
been defined; for example, port 23 is used for Telnet connections. There are also
custom sockets that users and developers define for their specific needs. The default
TCP/UDP port of the EKI-1511 Series Port1 is 5300. Users can adjust them
according to preference or application. Each port has its own data listen port to
accept the connection requests of other network device. The data listen port cannot
be set to the same value. You can transmit/receive data to/from devices via the data
listen port. 

4.3.3.3 Command Listen Port
Each port has its own command listen port to accept connection requests from other
network devices, so the command listen port cannot be set to the same value. The
Command Listen Port is different from the Data Listen port. <Default Port is 5400>
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4.4 USDG Control Mode
In controlling mode, the EKI-1511 Series device server presents a modem interface
to the attached serial device: it accepts AT-style modem commands to connect /
disconnect to other networking device. 
If you want a serial device running application program to connect/disconnect to
different devices on request, this function is available through the USDG Control
mode.

Figure 4.7 USDG Control Mode

4.4.1 Hangup Character
The default character is “+”. After you have connected to another serial device an via
EKI-1511 Series device, you may need to disconnect, using the command “+++”. To
do this, press “+” three times and wait for the Guard timeout <default value is
1000ms>; the device will disconnect. You can set “Guard Time” to define the idle
time.

4.4.2 Guard Time
The default value is 1000 ms. 
Example: <Guard Time>+++<Guard Time> 

Command Function
ATD <IP address><TCP port><CR> Forms a TCP connection to the specified host.

Ex: ATDT 192.0.55.22:5201
In above example, the EKI-1511 Series device server 
forms a raw TCP connection to the networking device 
(192.0.55.22). The TCP port is 5201.

ATA <CR> Answering an incoming call
+++<CR> Returns the user to the command prompt when 

entered from the serial port during a remote host con-
nection.

<LF><CR> OK <LF><CR> Commands are executed correctly
<LF><CR> CONNECT <LF><CR> Connect to other device
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4.5 RFC2217 Mode
RFC2217 mode is similar to virtual COM mode in that a driver is used to establish a
transparent connection between a host computer and a serial device by mapping the
serial port on EKI-1511 Series devices to a local COM port on a host computer.
RFC2217 defines general COM port control options based on the Telnet protocol.
Third party drivers supporting RFC2217 are widely available on the Internet and can
be used to implement virtual COM mapping to the serial port of your device.

Figure 4.8 RFC2217 Mode

<LF><CR> RING ddd.ddd.ddd 
<LF>< CR>

Detect the connection request from other device, 
which IP address is ddd.ddd.ddd.ddd.

<LF><CR> DISCONNECT 
<LF><CR>

Disconnect from other device

<LF><CR> ERROR <LF><CR> Incorrect commands
<LF><CR> FAIL <LF><CR> If you issue an ATDT command and can not connect 

to the device, it will response “FAIL”.

Command Function
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 5.1 Setting COM Port Redirector
Advantech COM port mapping software is a serial COM port redirector that creates
virtual COM ports and provides access to serial devices connected to an Advantech
serial device servers. Your serial device applications can communicate with serial
devices connected to the Advantech serial device servers without software changes. 
Since the virtual COM ports work like standard Windows COM ports, your application
software sees no difference between a local serial device and one connected to an
Advantech serial device server.
The COM redirector utility and the virtual COM port management utility are integrated
into one utility with same GUI. The Advantech Serial Device Server Configuration
Utility can create all Virtual COM ports using the Auto Mapping function or by using
the manual mapping function.

5.2 Virtual COM Port Mapping
5.2.1 Auto Mapping

1. On your desktop, navigate to Start > All Programs > EKI Device Configura-
tion Utility and click Advantech EKI Device Configuration Utility to open the 
utility.

2. Under Serial Device Servers, locate your server and click the icon to expand 
the listing.

3. Select the target device and right-click on it to open up the options menu 
window.

4. Locate Auto Mapping and select it. 

Figure 5.1 Selecting Auto Mapping
The Batch Automatic Mapping Virtual COM Port window displays.

5. Locate From System Port and click the drop-down menu to select the target 
COM port.

6. From the network address list, select the address options to map.
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The selected address displays the Device Port and (EKI-1511 Series device
server physical serial port) and the system port which will be the VCOM port for
the PC.

Figure 5.2 Selecting Auto Mapping 
7. From the network address list, select the address options to map.
8. Click Map Selected Ports to set the configuration.

Figure 5.3 Mapping Selected Ports
Once the mapping function is initialized, a successful mapping process results in the
virtual mapping of the designated physical serial port and VCOM PC port. See the
following figure.

Figure 5.4 Viewing VCOM Mapping Results

System Port

Device PortSelected Options
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 5.2.2 Manual Mapping
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utility to open the 
utility.

2. Under Serial Device Servers, locate your server and click the icon to expand 
the listing.

3. Select the target device and right-click on it to open up the options menu 
window.

4. Locate Manual Mapping and select it. 

Figure 5.5 Selecting Manual Mapping
The Manual Mapping Virtual COM Port window displays.

5. With the EKI-1511 Series, there is only a single port. It is not necessary to select 
from the Serial Port field. 

6. In the Host > COM Port drop-down menu, select the target COM port to map. 
This is the virtual port on the target PC.

Figure 5.6 Manual Mapping of Host Port
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7. Click Map it to continue the process. The mapping process may require a short 
time. Once this step is completed, the Manual Mapping Virtual COM Port 
window displays again to map the VCOM port on the target PC.
Once the mapping function is initialized, a successful mapping process results
in the virtual mapping of the designated physical serial port and VCOM PC port.
See the following figure.

Figure 5.7 Manual Mapping of a Virtual COM Port
To allow for an automatic connection after a reboot or a power up, click the
Auto Reconnect option to enable this function.

5.2.3 Configuration Wizard
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utility to open the 
utility.

2. Under Serial Device Servers, locate your server and click the icon to expand 
the listing.

3. From the tool bar, select Configuration Wizard. 

Figure 5.8 Selecting the Configuration Wizard
The Wizard screen displays and lists available devices.

4. Select the target device and click Next to continue.
The Wizard Device Settings window displays.

5. Under Serial Port Settings, click the Type drop-down menu and select the port 
type.
Review the settings under the Ethernet fields and verify them.

6. Click Next to continue or Previous to return to the previous screen.
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The selected settings are displayed in the following Wizard window.
7. Locate the radio button correlating to the target port to modify and click on it to 

select it.
Verify the Device Port (EKI-1511 Series device physical serial port) and System
Port (virtual COM port for PC) settings before continuing.

8. Click Finish to complete the process. A Wizard complete! screen displays 
indicating the completion of a successful procedure.

5.2.4 Confirming Virtual COM Settings
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utility to open the 
utility.

2. Locate Serial Ports menu in the menu pane and click on the Expand icon next 
to Virtual COM Ports to view a list of the mapped ports.

3. Select a system serial port to view its settings.

Figure 5.9 Serial Port Listing on EKI-1511 Series Device
For the next step, you will need to open the device manager on your system.
Using the Device Manager, you can both view and change the COM port
settings.

4. On your desktop, click on the Start button and then on Control Panel. A 
window displays showing all the available control panels.

5. Click on Hardware and Sound (Hardware). A list of all available hardware 
configuration options displays. 

Note! The following instructions were developed in a Windows 7 environment; 
the Windows XP equivalent is displayed in parentheses (). Instructions 
may vary according to the operating system used.
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6. Under Devices and Printers, click on the Device Manager link. A new window 
displays showing a list of all the available devices on your computer.

7. Locate Ports (COM & LPT) and click on the expand icon. A list of all available 
serial and parallel port devices display. 
The newly mapped VCOM port should be listed under the same mapped
settings used in the previous steps.

Figure 5.10 System Port VCOM Mapping Configuration
The newly mapped VCOM port is listed under the same mapped settings used
in the previous steps. The settings correspond to the VCOM port configuration
on the EKI-1511 Series device, see the following figure.

Figure 5.11 Verifying VCOM Mapping Configuration
If the settings do not correspond, the VCOM mapping is not correct. See “Virtual
COM Port Mapping” on page 42 to re-map the VCOM ports.
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 5.2.5 Removing VCOM Ports
1. On your desktop, navigate to Start > All Programs > EKI Device Configura-

tion Utility and click Advantech EKI Device Configuration Utility to open the 
utility.

2. Under Serial Ports, click the expand icon on Virtual COM Ports to view the 
configured port list.

3. Locate the port to remove and right-click on it to open the options menu.
4. Scroll down to Remove This Port and click on it to initiate the procedure.

Figure 5.12 Remove VCOM Port
A Remove Port confirmation window displays.

5. Click OK to continue with the removal process or Cancel to return to the 
previous menu.
Once the procedure is completed, a prompt displays the successful removal of
the port from the VCOM mapping list.
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5.2.6 Exporting and Importing VCOM Mapping
Importing and exporting Virtual COM Port Mapping is useful when the factory has
already used a number of serial device servers in VCOM mode. You can easily
upgrade to a new utility, and don’t need to re-map the Virtual COM Ports. For exam-
ple, when you would like to upgrade from Utility 1.71 to Utility 3.0, you can export
your own mapped Virtual COM Ports in Utility 1.71 and save them as a *.cpm file.
After upgrading to Utility 3.0, import your *.cpm file and restore your own Virtual COM
Ports.

1. On your desktop, navigate to Start > All Programs > EKI Device Configura-
tion Utility and click Advantech EKI Device Configuration Utility to open the 
utility.

2. Locate Serial Ports menu in the menu pane and click on the Expand icon next 
to Virtual COM Ports to view a list of the mapped ports.

3. Select a VCOM port.
4. Click Import Virtual COM Port Mapping or Export Virtual COM Port 

Mapping in the File menu.

5.3 Running a Diagnostic Test
The loopback test allows you to determine if the EKI-1511 Series device server is
configured correctly to identify any failed nodes in the network. The test allows you to
send a signal from the server and return (looped back) it back to the server.
1. Connect the loopack connector to a COM port on the EKI-1511 Series device 

server.
2. On your desktop, navigate to Start > All Programs > EKI Device 

Configuration Utility and click Advantech EKI Device Configuration Utility 
to open the utility.

3. Under Serial Ports, click the expand icon on Virtual COM Ports to view the 
configured port list.

4. Open the ICOMToolsPlus utility to open the EKI-1511 Series device server 
settings.

5. Set the COM port configuration to match the Port Configuration.
6. Click the Start menu.
A successful loopback test incrementally displays the Bytes/sec values on both dis-
played menus.

Note! This Virtual COM Port Mapping tool can only recover Virtual COM Ports 
that have been mapped previously. For newly installed serial device 
servers, please follow the virtual COM Port mapping steps.



Chapter 6
6Web Interface
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6.1 Overview
EKI-1511 Series serial device server can be configured through a web interface. By
using a standard web browser, the same procedure as with the Windows
configuration utility can be used. In the browser’s address field, enter the IP Address
of your EKI-1511 Series serial device server. The default IP setting is 10.0.0.1, but
you should use the IP which you have previously assigned for this device. Once the
IP is entered, you will be presented with the following windows.

6.2 Accessing the Web Page
6.2.1 Accessing the Web Page via Configuration Utility

To access the web page via configuration utility:
1. Select Ethernet under the desired device.
2. Click Launch Browser.

Figure 6.1 Accessing the Web Page via Configuration Utility

Note! Before using the web-based configuration, make sure your host PC 
Ethernet network IP domain is as same as the serial device server, or it 
can establish the TCP connection with the serial device server.

Note! It is recommended that you use Microsoft Internet Explorer 7.0 or 
higher.
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 6.2.2 Accessing the Web Page via Web Browser
Once the device is installed and connected, power on the device. The following
information guides you through the logging in process.
1. Launch your web browser on the PC.
2. In the browser’s address bar, type the device’s default IP address (Eth1: 

10.0.0.1).
The main menu is shown.

6.3 System
You can change the Device Name and Device Description on this page. You can also
enable or disable the Telnet and SNMP functions. Moreover, you can set the Time
zone related settings.
To access this page, click System.

Figure 6.2 System
The following table describes the items in the previous figure.

6.4 Ethernet Configuration
Choose Eth 1 in the Ethernet Configuration page. Enter the corresponding values for
your network environment. Remember press Save after fill in all values.

Item Description
Firmware version Displays the current firmware version of the device.
Revision number Displays the revision number of the device.
Device Name Enter the device name: up to 31 alphanumeric characters.
Device Description Enter the device description.
VCOM Ignore Device ID Click Enabled or Disabled to enable or disable VCOM ignore 

device ID.
Telnet Click Enabled or Disabled to set remote access through the 

Telnet Service function.
SNMP Click Enabled or Disabled to define the SNMP daemon.
Save Click Save to save the values and update the screen.
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To access this page, click Ethernet Configuration.

Figure 6.3 Ethernet Configuration
The following table describes the items in the previous figure.

Item Description
Mode Click the drop-down menu to select the IP Address Setting mode: 

Static or DHCP.
MAC Address Enter the MAC address to which packets are statically forwarded.
IP Address Enter a value to specify the IP address of the interface. The default 

is 192.168.1.1.
Subnet Mask Enter a value to specify the IP subnet mask for the interface. The 

default is 255.255.255.0.
Default Gateway Enter a value to specify the default gateway for the interface. The 

default is 192.168.1.254.
DNS Click the radio button to select the DNS mode: Automatic or 

Specific.
Current Status
IP 1 Displays the current IP address 1 of the device.
IP 2 Displays the current IP address 2 of the device.
IP 3 Displays the current IP address 3 of the device.
Save Click Save to save the values and update the screen.

Note! All new configurations will take effect after rebooting. To reboot the 
device, click Tools > Reboot.
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 6.5 Port Configuration
The serial port configuration menu has Basic, Operation Mode, and Advanced
Settings.

6.5.1 Basic
The Basic menu allows for the configuration of the serial interface type, baud rate,
parity, data / stop bits, and flow control for port configuration.
To access this page, click Port Configuration > Basic.

Figure 6.4 Port Configuration > Basic
The following table describes the items in the previous figure.

6.5.2 Operation
The Operation menu allows for the configuration of the mode type and related
attributes for port configuration.

Item Description
Type By default, the port type is set to L: RS-232, X: RS-422/485. 
Baud Rate Click the drop-down menu to select a baud rate, options include: 

300, 600, 1200, 1800, 2400, 4800, 7200, 9600, 14400, 19200, 
38400, 57600, 115200, and 230400. The value should conform to 
the current transmission speeds of connected devices when 
setting the baud rate.

Parity Click the drop-down menu to select the parity: None, Odd, Even, 
Mark or Space.

Data Bits Click the drop-down menu to select the data bits: 5, 6, 7, or 8.
Stop Bits Click the drop-down menu to select the stop bits: 1, 1.5 or 2.
Flow Control Click the drop-down menu to select the flow control mode: None, 

XOn/XOff, RTS/CTS
Save Click Save to save the values and update the screen.
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To access this page, click Port Configuration > Operation.

Figure 6.5 Port Configuration > Operation
The following table describes the items in the previous figure.

Item Description
Mode Click the drop-down menu to select the port configuration mode: 

Virtual COM Mode, USDG Data Mode, USDG Control Mode or 
RFC2217 Mode.

Host Idle Timeout(s) Enter a value to define the host idle timeout period.
Response Timeout(s) Enter a value to define the response timeout period.
Frame Break(ms) Enter a value to specify the frame break time.
Pack conditions (Pack sent immediately when reach 1024 Bytes)
By size Click the option to sent pack immediately by size.
By interval Click the option to sent pack immediately by interval.
By end-character Click the option to sent pack immediately by end-character.
Port Data Buffering
Media Click the drop-down menu to select port data buffering type: None 

or RAM.
When Data Full Click the drop-down menu to select process mode when data full: 

Stop.
Save Click Save to save the values and update the screen.
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 6.5.3 Advanced
The Advanced menu allows for the configuration of the time delay, buffer data size
and FIFO size for port configuration.
To access this page, click Port Configuration > Advanced.

Figure 6.6 Port Configuration > Operation
The following table describes the items in the previous figure.

6.6 Monitor
The EKI-1511 Series device server allows monitoring of the serial ports’ status. The
serial port’s operation mode and status is available for display. The IP address of the
host PC which is communicating with serial port is also displayed.
The Monitor function provides a method to monitor the serial device server’s status
(operation mode, baud rate, data bits, stop bits, parity and RTS/XON).
Monitoring information is divided into three main message types: Setting/Statistic/
Connected IP.

Item Description
Ignore Purge Click the option to purge the serial port when the serial port opens 

first time.
Disable Character 
Timeout Detection

Click the option to disable the serial port character timeout 
detection.

Disable Multiple 
Connection

Click the option to disable the multi-access function. Then only one 
TCP connection is allowed on this serial port.

Enable BufferData Size Click the option to enter the value to queue data to become a 
packet.

USDG Advanced Options (Flow Control will overwrite these options)
RTS Control Click the drop-down menu to select the status of RTS: ON, OFF, 

Toggle By Connect or Toggle By Data.
Save Click Save to save the values and update the screen.
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6.6.1 Setting
The Monitor Setting page allows for easy viewing of the port’s statistics.
To access this page, click Monitor > Setting.

Figure 6.7 Monitor > Setting
The following table describes the items in the previous figure.

Item Description
Operation Mode Display the current operation mode of the selected port.
Baud Rate Display the current baud rate of the selected port.
Data Bits Display the current data bits of the selected port.
Stop Bits Display the current stop bits of the selected port.
Parity Display the current parity of the selected port.
RTS/CTS Display the current RTS/CTS status of the selected port.
XON/XOFF Display the current XON/OFF status of the selected port.
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 6.6.2 Statistic
The Monitor Statistic page allows for easy viewing of the port’s TX/RX data count.
To access this page, click Monitor > Statistic.

Figure 6.8 Monitor > Statistic
The following table describes the items in the previous figure.

Item Description
Tx Count Display the current Tx count of the selected port.
Rx Count Display the current Rx count of the selected port.
Total Tx Count Display the current total Tx count of the selected port.
Total Rx Count Display the current total Rx count of the selected port.
RTS Display the current RTS status of the selected port.
CTS Display the current CTS status of the selected port.
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6.6.3 Connected IP
The Monitor Connected IP page allows for easy viewing of all connected device’s IP
address.
To access this page, click Monitor > Connected IP.

Figure 6.9 Monitor > Connected IP
The following table describes the items in the previous figure.

Item Description
Connected IP Displays the IP designation for the device.
IP Address Displays the current connected IP address of the selected port.
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 6.7 Auto Warning (Alarm)
You can set the e-mail server and SNMP Trap server in the Setting page, and set the
event type in the Event page.

6.7.1 Setting
The Alarm Setting menu includes three alarm setting menus for event notification:
Mail Sever, SNMP Trap Server, and the SNMP Agent Setting.
At the top of the list is the Mail Server setting which allows you to specify the mail
server to be used by the serial device server in order to deliver notifications to
selected Email accounts.
The SNMP Trap Server settings allows you to specify the management station of a
significant event by way of an unsolicited SNMP message.
The Simple Network Management Protocol (SNMP) is used by the serial device
server to collect detailed information about the serial device server.
To access this page, click Alarm > Setting.

Figure 6.10 Alarm > Setting
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The following table describes the items in the previous figure.

Item Description
Mail Server
Mail Server Enter the SMTP mail server.
From Email address Enter the email address.
Email address 1 Enter the email address 1 to receive alarm emails.
Email address 2 Enter the email address 2 to receive alarm emails.
Email address 3 Enter the email address 3 to receive alarm emails.
Email address 4 Enter the email address 4 to receive alarm emails.
SNMP Trap Server
Trap Server Enter the SNMP Trap server address.
Trap Server Port Enter the SNMP Trap server port.
Trap Version Click the radio button to select the SNMP version credentials: v1 or 

v2c.
Trap Community Enter the community string to be passed for the specified event.
SNMP Agent Setting
Read Community Enter the read-only, public, community string.
Write Community Enter the write-only, private, community string.
Contact Enter the individual designated the contact point for this event.
Location Enter the designated location/department of the setting.
Save Click Save to save the values and update the screen.
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 6.7.2 Event
The Alarm Event page allows the selection of system event triggers to select to and
define the notification channel.
To access this page, click Alarm > Event.

Figure 6.11 Alarm > Event 

The following table describes the items in the previous figure.

6.8 Syslogd
The EKI-1511 Series device server provides the functionality to allow network
devices to send event messages to a logging server, also known as a Syslog server,
by way of the Syslogd function. The Syslog protocol is supported by a wide range of
devices and can be used to log different types of events.

6.8.1 Syslogd Setting
Users can enable the syslogd function to record historical events or messages locally
or on a remote syslog server.

Item Description
System Event
Cold Start Click the option to select a warning type when the device server’s 

power is cut off and reconnected.
Warm Start Click the option to select a warning type when the device server is 

reboot.
Authentication failure Click the option to select a warning type when an incorrect 

password is entered.
IP address changed Click the option to select a warning type when the IP address is 

changed.
Password changed Click the option to select a warning type when the password is 

changed.
Ethernet1 link down Click the option to select a warning type when the Ethernet 1 port 

is disconnected.
Save Click Save to save the values and update the screen.
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To access this page, click Syslogd > Syslogd Setting.

Figure 6.12 Syslogd > Syslogd Setting
The following table describes the items in the previous figure.

6.8.2 Syslogd Message
After enabling the syslogd function, users can check the history in the syslogd
message page.
To access this page, click Syslogd > Syslogd Message.

Figure 6.13 Syslogd > Syslogd Message

Item Description
Syslogd Click Enabled or Disabled to set the logging service status.
Save Click Save to save the values and update the screen.
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 6.9 Tools
The EKI-1511 Series device server provides tools for access to ping and reset
functions.

6.9.1 Ping
The Ping page can help users diagnose Ethernet problems. Users can use the ping
page to ask the device to ping a specific target to check the Ethernet network status.
The Ping page allows you to configure the test log page.
To access this page, click Tools > Ping.

Figure 6.14 Tools > Ping
The following table describes the items in the previous figure.

Item Description
IP Enter the IP address or host name of the station to ping. The initial 

value is blank. The IP Address or host name you enter is not 
retained across a power cycle. Host names are composed of 
series of labels concatenated with periods. Each label must be 
between 1 and 63 characters long, maximum of 64 characters.

Size Enter the size of ping packet. The default value is 56. The value 
ranges from 8 to 5120. The size entered is not retained across a 
power cycle.

Count Enter the number of echo requests to send. The default value is 4. 
The value ranges from 1 to 5. The count entered is not retained 
across a power cycle.

Run ping Display the ping reply format.
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6.9.2 Reboot
The configuration will take effect after clicking Save button. All configurations are
saved to flash memory after a system reboot. Press the Reboot button and the
system will give a reset response. It will take a few seconds to reconnect with the
new values.
To access this page, click Tools > Reboot.

Figure 6.15 Tools > Reboot
Click Yes to reboot the serial device server. Any configuration changes you have
made since the last time you saved will be lost.

6.10 Management
The EKI-1511 Series device server allows for easy installation and maintenance and
reliable maintenance access from anywhere. With the reliable management tools
available, you can streamline staffing and troubleshooting requirements to a
centralized system.

6.10.1 Log File
If users enable the system event or serial event to log in file, users can download the
log file from here.
To access this page, click Management > Log File.

Figure 6.16 Management > Log File
The following table describes the items in the previous figure.

Item Description
System Log File Click the drop-down menu to select a specific action for the system 

log file. Available options: Download System Log, Remove System 
Log, Download and Remove System Log.

Export Click Export to download the log file.
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 6.10.2 Change Password
The Change Password function allows you to easily update your current password
from a single menu.
To access this page, click Management > Change Password.

Figure 6.17 Management > Change Password
The following table describes the items in the previous figure.

If you have set a password through the configuration utility or Telnet or serial
console, when you access the web configuration, you need to key in the password. It
is not necessary to enter the user name in the dialog.
If you want to disable the password protection, change the password to default option
None (leave the new password column blank). Be sure to press the Save button and
reboot the serial device server to make the change effective.

6.10.3 Secure access IP
To access this page, click Management > Secure access IP.

Figure 6.18 Management > Secure access IP
The following table describes the items in the previous figure.

6.10.4 Export Device Settings
Export the server configuration settings to a .conf file.
To access this page, click Management > Export.
Click Export to export the serial device server settings.

Item Description
New password Enter the character set for the define password type.
New password again Retype the password entry to confirm the profile password.
Save Click Save to save the values and update the screen.

Item Description
Access IP number Enter a value to define access IP number 
Save Click Save to save the values and update the screen.
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6.10.5 Import Device Settings
Import the server configuration settings to a .conf file. 
To access this page, click Management > Import.

Figure 6.19 Management > Import
The following table describes the items in the previous figure.

Item Description
Choose File Click Choose File to select the configuration file.
Submit Click Submit to backup the settings.



Chapter 7
7Telnet/Serial Console 
Configuration
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7.1 Overview
The purpose of the Console Configuration is to help you manage your device in con-
sole mode. One of the main functions of the console mode is to change the web con-
figuration login password. You can use terminal software like Hyper Terminal, Telix
and other related terminal software.

7.2 Telnet Console
7.2.1 Create a new connection

You can create a new Telnet connection and assign a connection name for the con-
sole configuration.

Figure 7.1 Creating a Telnet Connection
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 7.2.2 Input the IP address
Confirm that the Telnet console configuration works. Click OK. Be sure that your host
PC Ethernet network IP domain is as same as the EKI-1511 Series device server,
and the Telnet TCP port number is “23”.

Figure 7.2 Creating a Telnet Connection

7.2.3 Connection Success
After connecting to the serial device server in HyperTerminal console, a welcome
greeting displays.

Figure 7.3 Telnet Connection Console
At the command prompt, you can type a “help” followed by the Enter button, or
<Tab> twice, to display the command list.
You can toggle between the different command menu options. 
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7.3 Command List

7.3.1 system
Usage: system

Show current device status and informations.
Usage: system name [Maximum length 31 bytes]

Set current device name.
Usage: system desc [Maximum length 127 bytes]

Set current device description.

7.3.2 port
Usage: port [nn|all]

Show port status and informations.
Usage: port [nn] desc [Maximum length 127 bytes]

Set serial port description.
Usage: port [nn|all] type 232 flow []

Set serial port type and flow control.
– flow 0:None.
– flow 1:XOn/XOff.
– flow 2:RTS/CTS.

Usage: port [nn|all] baud [300-230400] parity [] data [5-8] stop [1|1.5|2]
Set serial baud rate, parity and numbers of data bits, numbers of stop bits.
Acceptable baud: 300, 600, 1200, 1800, 2400, 4800, 7200, 9600, 14400,
19200, 38400, 57600, 115200, and 230400
– parity n: None Parity.
– parity e: Even Parity.
– parity o: Odd Parity.
– parity m: Mark Parity.
– parity s: Space Parity.

Command Function Description
system Show or configure the system information
port Show or configure the serial ports information
portadv Show or configure the serial ports advanced settings
mvcom Show or configure the serial ports in Virtual COM mode
mctrl Show or configure the serial ports in Control mode (USDG)
mdata Show or configure the serial ports in Data mode (USDG)
net Show or configure the Ethernet ports settings
password Set or change the password
alarm Show or configure the auto warning functions including mail alarm and 

SNMP alarm
monitor Monitor the serial ports status
mrfc2217 Show all port modes and mode information.
apply Write settings to the flash memory and reboot the system immediately
exit Terminate the shell session
help Display command list help information
reboot Write settings and reboot the system immediately.
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Usage: port [nn|all] mode [vcom|ctrl|data]
Set serial port as virtual COM port or control mode or data mode.

7.3.3 portadv
$ help portadv

Show port advanced setting.
Usage: portadv [nn|all] delayT []

Set delay time(ms).
Usage: portadv [nn|all] ignorepurge [TRUE|FALSE] dischato [TRUE|FALSE] dismulti-
con [TRUE|FALSE]

Enable or disable the feature of ignore purge,
Disable character timeout detection, and disable multiple connection.

Usage: portadv [nn|all] databuf []
Set databuffer threshold.

Usage: portadv [nn|all] rts []
Set port RTS status.
– value 0: None Setting.
– value 1: Setting power on.
– value 2: Setting accept on.
– value 4: Setting transmission on.

7.3.4 mvcom
Usage: mvcom

Show all port mode and mode informations.
Usage: mvcom [nn|all]

Set port [nn|all] as virtual COM port mode.
Usage: mvcom [nn|all] idleto []

Set host idle timeout(s).
Usage: mvcom [nn|all] respto [] framebk []

Set response timeout(ms) and frame break(ms).
Usage: mvcom [nn|all] bysize []
Usage: mvcom [nn|all] bytime []
Usage: mvcom [nn|all] bychar [NULL|]

Set datapackage as size (bytes) or time (ms) and character (HEX).
– value 0: None Setting.

7.3.5 mctrl
Usage: mctrl

Show port mode and mode informations.
Usage: mctrl [nn|all]

Set port [nn|all] as control mode.
Usage: mctrl [nn|all] idleto [] tcpp [] atp [] guardt [] hangchr []

Set data idle timeout(s) data listen port command listen port guard time(ms)
hangup character.
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7.3.6 mdata
Usage: mdata

Show port mode and mode informations.
Usage: mdata [nn|all]

Set port [nn|all] as data mode.
Usage: mdata [nn|all] protocol [TCP|UDP]

Set transmit protocol as TCP or UDP.
Usage: mdata [nn|all] idleto [] lsport [] atport []

Set data idle timeout(s) listen port and AT command port.
Usage: mdata [nn|all] respto [] framebk []

Set response timeout(ms) and frame break(ms).
Usage: mdata [nn|all] bysize [] bytime [] bychar [NULL|] bychartimeout [ON|OFF]

Set datapackage as size (bytes) or time (ms) or character (HEX) and character-
timeout.
– value 0: None Setting.

Usage: mdata [nn|all] autopeerip [ON|OFF]
Set auto connect to peer ip as on or off.

Usage: mdata [nn|all] peernum [1-16] peer [d.d.d.d:d] ...
Set peer IP address and port for receive data.

7.3.7 net
Usage: net [1|2]

Show device network status and informations.
Usage: net [1|2] mode [static|dhcp|bootp|all]

Set network operating mode.
Usage: net [1|2] ip [d.d.d.d] netmask [d.d.d.d] gw [d.d.d.d]

Set IP address and subnet mask and gateway.
Usage: net [1|2] dns [auto|specific]

Enable/Disable DNS.
Usage: net [1|2] dns1 [d.d.d.d]

Set network DNS1.
Usage: net [1|2] dns2 [d.d.d.d]

Set network DNS2.
Usage: net [1|2] to [d]

Set network timeout.

7.3.8 password
Usage: password

Display two different Usage.
Usage: password new [1-31 characters]

Set new password.
Usage: password old [**...] new [1-31 characters]

Confirm the old password and set new password.

7.3.9 alarm
Usage: alarm
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Show current alarm informations.
Usage: alarm mail server [null|address] from [null|address] to1 [null|address] to2
[null|address] to3 [null|address] to4 [null|address]

Set current mail server configuration.
Usage: alarm trap server [null|address] ver [1|2] community [null|name]

Set current trap server configuration.
Usage: alarm agent rcommunity [null|name] wcommunity [null|name] contact
[null|name] location [null|name]

Set current snmp agent configuration.
Usage: alarm event mail [cstart] [wstart] [auth] [ip] [passwd] [eth1]

Set current mail event configuration.
Usage: alarm event trap [cstart] [wstart] [auth] [eth1]

Set current trap event configuration.

7.3.10 monitor
Usage: monitor port [1|2|..] setting

Monitor COM port setting.
Usage: monitor port [1|2|..] statistic

Monitor COM port statistic data.
Usage: monitor port [1|2|..] ip

Monitor connected IP.

7.3.11 time
Usage: time

Show current time informations.
Usage: time [YYYYMMDDhhmmss]

Set current time configuration.
Usage: time ntp [timeserver]

Set current time server configuration.
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7.3.12 service
Usage: service telnet [enable|disable]

Enable/Disable telnet function.
Usage: service snmp [enable|disable]

Enable/Disable SNMP function.

7.3.13 mrfc2217
Usage: mrfc2217

Show all port mode and mode informations.
Usage: mrfc2217 [nn|all]

Set port [nn|all] as RFC2217 mode.
Usage: mrfc2217 [nn|all] idleto [] lsport []

Set host idle timeout(s) and listen port.

7.3.14 apply
Usage: apply

Save the settings to flash and reboot right now.

7.3.15 exit
Usage: exit

Terminate shell session.

7.3.16 help
Usage: help [cmd]

Display help information of command cmd.

7.3.17 reboot
Usage: reboot

Write settings and reboot the system immediately.
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8.1 List of Known TCP and UDP Port Numbers

Port Protocol Service
5048 (TCP/UDP) Configuration Utility
5058 (TCP/UDP) Configuration Utility
5202 (TDP) VCOM
9999 (TDP) Firmware Download
22 (TDP) SSH
23 (TDP) Telnet
25 (TDP) SMTP (Mail Client)
53 (TCP/UDP) DNS
67 (UDP) BOOTP Server/DHCP
68 (UDP) BOOTP Client/DHCP
80 (TDP) Web Interface/HTTP
123 (TDP) NTP
161 (TDP) SNMP
162 (TCP/UDP) SNMP Trap
443 (TDP) HTTPS
502 (TDP) Modbus/TCP (Default)
514 (TDP) Syslog
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